[cairo] Some other bits...
cworth at cworth.org
Wed Aug 17 10:53:58 PDT 2005
On Wed, 17 Aug 2005 13:39:36 -0400 (EDT), Behdad Esfahbod wrote:
> > These functions return identical values! I.e. integer_part() is
> > returning floor(), in a much more efficient way.
While people are looking at this. I would suggest some name
improvements as well:
_cairo_fixed_from_int -> _cairo_fixed_from_integer
_cairo_fixed_integer_floor -> _cairo_fixed_to_integer_floor
_cairo_fixed_integer_ceil -> _cairo_fixed_to_integer_ceil
_cairo_fixed_integer_part need not exist as a name, as mentioned
And as also mentioned, it would be possible to have rounding away from
zero (_to_integer_round) and toward zero (_to_integer_trunc), but we
don't need these nor do we anticipate needing them.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Size: 189 bytes
Desc: not available
Url : http://lists.freedesktop.org/archives/cairo/attachments/20050817/80bf18a8/attachment.pgp
More information about the cairo