[cairo] clip-getters [patch]
rocallahan at novell.com
Thu Nov 23 13:53:59 PST 2006
On Thu, 2006-11-23 at 20:34 +0100, Torsten Schoenfeld wrote:
> On Sat, 2006-09-30 at 21:27 +1200, Robert O'Callahan wrote:
> > > > I vote for rectangle_list. An array is just an implementation of a
> > > > list :-).
> > > It looks like this got pushed without any change in this area.
> > >
> > > I think I like the function name that got pushed
> > > (cairo_copy_clip_rectangles) more than I would like
> > > cairo_copy_clip_rectangle_list.
> > It was an oversight. I did rename the destructor to
> > cairo_rectangle_list_destroy.
> > Based on the other emails in this thread, it seems best to rename
> > cairo_copy_clip_rectangles to cairo_copy_clip_rectangle_list. OK?
> Looks like this hasn't happened yet. So, what's the status on
> rectangles versus rectangle_list?
I'm still waiting for a response to the "OK?"
I should have ping Carl but I slackly forgot
More information about the cairo