dbus/doc TODO,1.25,1.26

Havoc Pennington hp@pdx.freedesktop.org
Sat, 11 Oct 2003 17:55:13 -0700


Update of /cvs/dbus/dbus/doc
In directory pdx:/tmp/cvs-serv30697/doc

Modified Files:
	TODO 
Log Message:
2003-10-11  Havoc Pennington  <hp@pobox.com>

	* test/decode-gcov.c (function_solve_graph): make broken block
	graph a nonfatal error since it seems to be broken. Need to debug
	this.

	* dbus/dbus-marshal.c (_dbus_type_is_valid): new function since we
	can't just check type > INVALID < LAST anymore

	* dbus/dbus-message.c (dbus_message_get_signature): new function
	(dbus_message_has_signature): new function
	(struct DBusMessage): add signature field (right now it isn't sent
	over the wire, just generated on the fly)
	(dbus_message_copy): copy the signature, and init strings to
	proper length to avoid some reallocs
	(dbus_message_iter_init_array_iterator): return void, since it
	can't fail
	(dbus_message_iter_init_dict_iterator): return void since it can't fail
	(_dbus_message_loader_queue_messages): add silly temporary hack to
	fill in message->signature on load

	* dbus/dbus-protocol.h: change DBUS_TYPE_* values to be ASCII
	characters, so they are relatively human-readable.



Index: TODO
===================================================================
RCS file: /cvs/dbus/dbus/doc/TODO,v
retrieving revision 1.25
retrieving revision 1.26
diff -u -d -r1.25 -r1.26
--- TODO	11 Oct 2003 06:20:28 -0000	1.25
+++ TODO	12 Oct 2003 00:55:11 -0000	1.26
@@ -93,3 +93,17 @@
 
  - re_align_field_recurse() in dbus-message.c is broken because it 
    crashes on some types of header field values. security problem.
+
+ - the system daemon has to be able to reload changes to the 
+   security policy without restarting, because apps won't 
+   be coded to handle it restarting
+
+ - modify the wire protocol to keep the args signature separate 
+   from the args themselves. Make the name of TYPE_NAMED part 
+   of the type signature, rather than part of the value.
+   Then you have the full typecheck in a single string.
+
+ - rename TYPE_NAMED to TYPE_CUSTOM, probably a clearer name.
+
+ - dbus_message_iter_init_array_iterator has "iter" and "iterator" 
+   in the same function name