Proposal and RFC: DAL, the Desktop Abstraction Layer

Ikke eikke@eikke.com
Wed Jan 19 03:31:01 PST 2005


>   A few things:
> 
> Interfaces:
> 
>   <Interface>org.freedesktop.DIS.MusicPlayer</Interface>
> 
> This would be better as :
> <Interfaces>
> <Interface name="org.freedesktop.MusicPlayerInterface">Interface 
> Description here </Interface>
> </Interfaces>
> 
> Bear in mind a service can have multiple interfaces and I believe 
> interfaces should be in A.B.C format (not A.B.C.D).
Actually, no. One application can implement multiple services (I am a
MusicPlayer AND a VideoPlayer, for example), but one service (the
MusicPlayer service) is bound to one interface. I can't think of a case
where it wouldn't be (or where it should be necessary to assign multiple
interfaces to a service).

> Events:
> 
>   <Event name="NewTrackStarted">
> 
> I am used to events having the word "On" prefixed to them so as to 
> distinguish them from methods so it would be nice if it where:
> 
> <Event name="OnNewTrackStarted">
To Java- or (even worse) VisualBasic-ish ;) It's an event sent by the
app delivering the service, the "On" should be inside the name of a
function reacting on the event.

> Also you have a method called "OnTurntable" could you not replace that 
> with "GetCurrentTrackURI"
True. Couldn't figure out a better name at the moment of writing :)

> (I would also think you would need SetCurrentTrackURI instead of PlaybackURI too - its a good idea to use 
> Get/Set methods where relevant as these would then translate nicely into 
> GObject properties and in this case CurrentTrackURI would be such a 
> read/write property)
SetCurrentTrackUri isn't really a "logical" name IMHO, caus it doesnt
says we also request the player to start playback.
Maybe there should be 2 functions: SetCurrentTrackUri, and StartPlayback
(next to PausePlayback etc). ResumePlayback could be obsoleted then too.

I'll update the thing today, if possible.

> jamie.

Ikke
http://www.eikke.com


More information about the dbus mailing list