D-Bus 1.3.0 released

Michael Biebl mbiebl at gmail.com
Thu Aug 6 17:33:34 PDT 2009

2009/8/7 Lennart Poettering <mzqohf at 0pointer.de>:
> On Fri, 07.08.09 02:11, Michael Biebl (mbiebl at gmail.com) wrote:
>> > How does that matter? Automake is only required for folks who build
>> > from git, i.e. developers. And those should not have a problem with
>> > keeping there system up-to-date.
>> >
>> > I do see value that the tarball stays compilable on older
>> > distributions, since it is used by admins and other non-developer
>> > folks. But the git tree? If someone uses that he should be expected to
>> > keep his things up-to-date.
>> >
>> > 1.11 is two months old already now.
>> silent-rules is not a crucial feature, so it doesn't really cost you
>> anything to keep the support optional.
>> I'm not sure if every developer (or tester ftm) is running the latest
>> bleeding edge distro.
>> I personally won't install automake-1.11 from sources just to
>> (test-)compile dbus.
>> It also makes it easier for distros, in case they need to patch the
>> build system and rerun the autotools.
> I don't really buy this. Somehow I get the idea that all this is about
> is that Debian is glacial in updating automake, right?

You were asking for feedback and imho it makes sense to be
conservative in such matters.

> But anyway, since today's your birthday I have now reworked that patch
> to make you happy.

No birthday but thanks anyway ;-)


Why is it that all of the instruments seeking intelligent life in the
universe are pointed away from Earth?

More information about the dbus mailing list