DBus method naming of upower/udisks

David Zeuthen david at fubar.dk
Fri Dec 11 07:57:58 PST 2009

On Fri, 2009-12-11 at 02:11 -0800, randyf at sibernet.com wrote:
>    So thinking about this a bit more, the question that should be
> asked here is "what *is* this project"?  What is or should be the
> expectaction, requirements, or architecture of the project formally
> known as DeviceKit-Disks (or 'Power', for that matter)?
>    Defining that any of this should change from previous definitions 
> (whether the previous or new is either weak or strong) demands that
> the project can accurately describe what it provide and why it should
> have the name that has been given (or any paths or namespace).

The README file for udisks right now states

 The udisks project provides

  o  A storage daemon that implements well-defined D-Bus interfaces
     that can be used to query and manipulate storage devices.

  o  a command-line tool, udisks(1), that can be used to query and
     use the daemon

which I think is (somewhat) accurate but also very sparse. I hope my
previous message clarifies this a lot more - including what kind of
interfaces we're aiming to provide now - and in the future. It would be
good to condense some of that and put it in the README or HACKING file.


More information about the devkit-devel mailing list