[PATCH 04/12] drm: remove unused save/restore fields from drm_connector & fix comments

Chris Wilson chris at chris-wilson.co.uk
Mon Nov 7 12:26:59 PST 2011


On Mon,  7 Nov 2011 12:03:15 -0800, Jesse Barnes <jbarnes at virtuousgeek.org> wrote:
> Also fix up the wrapping to 80 columns.
> 
> Signed-off-by: Jesse Barnes <jbarnes at virtuousgeek.org>
> ---
>  include/drm/drm_crtc.h |   20 +++++++-------------
>  1 files changed, 7 insertions(+), 13 deletions(-)
> 
> diff --git a/include/drm/drm_crtc.h b/include/drm/drm_crtc.h
> index ad2a605..6ab20f8 100644
> --- a/include/drm/drm_crtc.h
> +++ b/include/drm/drm_crtc.h
> @@ -386,26 +386,19 @@ struct drm_crtc {
>  /**
>   * drm_connector_funcs - control connectors on a given device
>   * @dpms: set power state (see drm_crtc_funcs above)
> - * @save: save connector state
> - * @restore: restore connector state
>   * @reset: reset connector after state has been invalidate (e.g. resume)
> - * @mode_valid: is this mode valid on the given connector?
> - * @mode_fixup: try to fixup proposed mode for this connector
> - * @mode_set: set this mode
>   * @detect: is this connector active?
> - * @get_modes: get mode list for this connector
> + * @fill_modes: build a mode list for this connector
>   * @set_property: property for this connector may need update
>   * @destroy: make object go away
>   * @force: notify the driver the connector is forced on
>   *
>   * Each CRTC may have one or more connectors attached to it.  The functions
> - * below allow the core DRM code to control connectors, enumerate available modes,
> - * etc.
> + * below allow the core DRM code to control connectors, enumerate available
> + * modes, etc.
>   */
>  struct drm_connector_funcs {
>  	void (*dpms)(struct drm_connector *connector, int mode);
> -	void (*save)(struct drm_connector *connector);
> -	void (*restore)(struct drm_connector *connector);
>  	void (*reset)(struct drm_connector *connector);
>  
>  	/* Check to see if anything is attached to the connector.
> @@ -416,9 +409,10 @@ struct drm_connector_funcs {
>  	 */
>  	enum drm_connector_status (*detect)(struct drm_connector *connector,
>  					    bool force);
> -	int (*fill_modes)(struct drm_connector *connector, uint32_t max_width, uint32_t max_height);
> -	int (*set_property)(struct drm_connector *connector, struct drm_property *property,
> -			     uint64_t val);
> +	int (*fill_modes)(struct drm_connector *connector, uint32_t max_width,
> +			  uint32_t max_height);

Attack of the random 80-column limit!

int (*fill_modes)(struct drm_connector *connector,
		  uint32_t max_width,  uint32_t max_height);

keeps the logically more connected width&height together.

What colour do you want your bikeshed today?
-Chris

-- 
Chris Wilson, Intel Open Source Technology Centre


More information about the dri-devel mailing list