[Bug 42998] New: [r600g] Regression: EVE Online graphics borked again (bisected)

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Wed Nov 16 10:27:19 PST 2011


             Bug #: 42998
           Summary: [r600g] Regression: EVE Online graphics borked again
    Classification: Unclassified
           Product: Mesa
           Version: git
          Platform: x86-64 (AMD64)
        OS/Version: Linux (All)
            Status: NEW
          Severity: normal
          Priority: medium
         Component: Drivers/Gallium/r600
        AssignedTo: dri-devel at lists.freedesktop.org
        ReportedBy: luziphermcleod at yahoo.ie

Created attachment 53609
  --> https://bugs.freedesktop.org/attachment.cgi?id=53609
Screenshot of login screen (bad)

EVE Online (via wine, usually works well) has severe graphical glitches on
r600g (HD4870). It's unplayable now. I bisected this down to:

r600g: lazy load for AR register
commit: 8e366dc365d01213b71b87ace47d30938db74845

It seems that all triangles (I guess) are malformed, jump around and aren't
textured as they should. Also the system gets quite slow as long as the game is

Gentoo on vanilla kernel linux-3.2.0-rc2
Mesa from git, r600g driver
GPU: Radeon HD4870 (x2, only one used), CPU: Intel Core i7-965, MB: ASUS P6T
libdrm from git, xf86-video-ati from git, wine-1.3.32, xorg-server-1.11.2

Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the dri-devel mailing list