[PATCH libdrm 3/5] modetest: print more about our properties

Paulo Zanoni przanoni at gmail.com
Sat Apr 21 13:49:36 PDT 2012

2012/3/29 Eugeni Dodonov <eugeni at dodonov.net>:
> On Thu, Mar 29, 2012 at 18:28, Paulo Zanoni <przanoni at gmail.com> wrote:
> <really-small-bikeshedding>
> I don't know if it should go into a separate patch though. But it is aligned
> to the other formatting patterns you do, and it certainly looks nicer this
> way, and it shouldn't break anything anyway. So I am fine either way :).
> </really-small-bikeshedding>

I agree, but it's a single-line change that does not make much sense without
this patch, so I decided to not have a patch that just replaces "  " with "\t".

>> The previous function dump_props also segfaulted when we didn't have
>> enought permissions. The new function does not segfault in this case (by
>> checking for the return value of drmModeGetProperty).
> <another-bikeshedding>
> I think this could be done in a separate patch..
> </another-bikeshedding>

No. This is just a note like "the function I just killed had a bug,
the function
that replaces it does not have the same bug". It would make no sense
to send a
patch to fix the old function, then send this patch replacing the
function. Why fix it if you're going to replace it?

Paulo Zanoni

More information about the dri-devel mailing list