[PATCH] drm: cleanup: use drm_framebuffer_reference instead of a kref_get

Daniel Vetter daniel at ffwll.ch
Wed Apr 10 02:18:26 PDT 2013


On Wed, Apr 10, 2013 at 02:29:39PM +0530, Archit Taneja wrote:
> drm_framebuffer_lookup() does a kref_get() for the framebuffer if it finds one
> corresponding to the fb id passed to it. Use drm_framebuffer_reference() instead
> for clarity since it's the function used in other places to take a reference.
> 
> Signed-off-by: Archit Taneja <archit at ti.com>

Reviewed-by: Daniel Vetter <daniel.vetter at ffwll.ch>
> ---
>  drivers/gpu/drm/drm_crtc.c |    2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/drivers/gpu/drm/drm_crtc.c b/drivers/gpu/drm/drm_crtc.c
> index dd64a06..a3b63cf 100644
> --- a/drivers/gpu/drm/drm_crtc.c
> +++ b/drivers/gpu/drm/drm_crtc.c
> @@ -412,7 +412,7 @@ struct drm_framebuffer *drm_framebuffer_lookup(struct drm_device *dev,
>  	mutex_lock(&dev->mode_config.fb_lock);
>  	fb = __drm_framebuffer_lookup(dev, id);
>  	if (fb)
> -		kref_get(&fb->refcount);
> +		drm_framebuffer_reference(fb);
>  	mutex_unlock(&dev->mode_config.fb_lock);
>  
>  	return fb;
> -- 
> 1.7.10.4
> 

-- 
Daniel Vetter
Software Engineer, Intel Corporation
+41 (0) 79 365 57 48 - http://blog.ffwll.ch


More information about the dri-devel mailing list