[PATCH v2 3/4] drm/i915: pre-alloc instead of drm_mm search/get_block

Chris Wilson chris at chris-wilson.co.uk
Sat Jul 27 06:15:24 PDT 2013


On Sat, Jul 27, 2013 at 03:09:48PM +0200, David Herrmann wrote:
> Hi
> 
> On Sat, Jul 27, 2013 at 3:06 PM, Chris Wilson <chris at chris-wilson.co.uk> wrote:
> > On Sat, Jul 27, 2013 at 01:38:42PM +0200, David Herrmann wrote:
> >> i915 is the last user of the weird search+get_block drm_mm API. Convert it
> >> to an explicit kmalloc()+insert_node(). This drops the last user of the
> >> node-cache in drm_mm. We can remove it now in a follow-up patch.
> >>
> >> v2:
> >>  - simplify error path in i915_setup_compression()
> >
> > You only applied it to the err path, I was expecting err_fb to do the
> > kfree(compressed_llb) as well. Feel free to rename those to err_fb and
> > err_llb respectively if you think that helps.
> 
> I wasn't sure about that second error-path. Some kernel subsystems
> tend to inline error-paths that are only taken once (which is the case
> for compressed_llb). But if that's not the case for DRM, I will surely
> fix that, too.

My concern in this case is to keep the two path similar; we use the same
allocation style so we should use the same cleanup. Otherwise, the next
time I look at the code, I wil wonder why they are different. :)
-Chris

-- 
Chris Wilson, Intel Open Source Technology Centre


More information about the dri-devel mailing list