[PATCH 2/2] drm/atomic: add plane iterator macros

Daniel Vetter daniel at ffwll.ch
Fri Nov 21 12:38:40 PST 2014


On Fri, Nov 21, 2014 at 03:28:32PM -0500, Rob Clark wrote:
> Add helper macros to iterate the current, or incoming set of planes
> attached to a crtc.  These helpers are only available for drivers
> converted to use atomic-helpers.
> 
> Signed-off-by: Rob Clark <robdclark at gmail.com>
> ---
>  Documentation/DocBook/drm.tmpl  |  1 +
>  include/drm/drm_atomic_helper.h | 26 ++++++++++++++++++++++++++
>  2 files changed, 27 insertions(+)
> 
> diff --git a/Documentation/DocBook/drm.tmpl b/Documentation/DocBook/drm.tmpl
> index 8c54f9a..3789f2d 100644
> --- a/Documentation/DocBook/drm.tmpl
> +++ b/Documentation/DocBook/drm.tmpl
> @@ -2343,6 +2343,7 @@ void intel_crt_init(struct drm_device *dev)
>  	<title>Atomic State Reset and Initialization</title>
>  !Pdrivers/gpu/drm/drm_atomic_helper.c atomic state reset and initialization
>        </sect3>
> +!Iinclude/drm/drm_atomic_helper.h
>  !Edrivers/gpu/drm/drm_atomic_helper.c
>      </sect2>
>      <sect2>
> diff --git a/include/drm/drm_atomic_helper.h b/include/drm/drm_atomic_helper.h
> index 64b4e91..42d56e6 100644
> --- a/include/drm/drm_atomic_helper.h
> +++ b/include/drm/drm_atomic_helper.h
> @@ -96,5 +96,31 @@ drm_atomic_helper_connector_duplicate_state(struct drm_connector *connector);
>  void drm_atomic_helper_connector_destroy_state(struct drm_connector *connector,
>  					  struct drm_connector_state *state);
>  
> +/**
> + * drm_crtc_for_each_plane - iterate over planes currently attached to crtc
> + * @plane: the loop cursor
> + * @crtc:  the crtc whose planes are iterated
> + *
> + * This iterates over the current state, useful (for example) when applying
> + * atomic state after it has been checked and swapped.  To iterate over the
> + * planes which *will* be attached (for ->atomic_check()) see
> + * drm_crtc_for_each_pending_plane()
> + */
> +#define drm_crtc_for_each_plane(plane, crtc) \
> +	list_for_each_entry((plane), &(crtc)->dev->mode_config.plane_list, head) \
> +		if ((crtc)->state->plane_mask & (1 << drm_plane_index(plane)))

Implement this as drm_crtc_for_each_pending_plane(plane, (crtc)->state)?
Which means _pending is a strange name ...
-Daniel

> +
> +/**
> + * drm_crtc_for_each_pending_plane - iterate over attached planes in new state
> + * @plane: the loop cursor
> + * @crtc_state: the incoming crtc-state
> + *
> + * Similar to drm_crtc_for_each_plane(), but iterates the planes that will be
> + * attached if the specified state is applied.  Useful during (for example)
> + * ->atomic_check() operations, to validate the incoming state
> + */
> +#define drm_crtc_for_each_pending_plane(plane, crtc_state) \
> +	list_for_each_entry((plane), &(crtc_state)->state->dev->mode_config.plane_list, head) \
> +		if ((crtc_state)->plane_mask & (1 << drm_plane_index(plane)))
>  
>  #endif /* DRM_ATOMIC_HELPER_H_ */
> -- 
> 1.9.3
> 

-- 
Daniel Vetter
Software Engineer, Intel Corporation
+41 (0) 79 365 57 48 - http://blog.ffwll.ch


More information about the dri-devel mailing list