[PATCH] drm/ttm: use swap macro in ttm_bo_handle_move_mem

Christian König christian.koenig at amd.com
Fri Jul 13 06:41:37 UTC 2018


Am 13.07.2018 um 04:37 schrieb Sinclair Yeh:
> On Mon, Jul 09, 2018 at 10:24:47AM -0500, Gustavo A. R. Silva wrote:
>> Make use of the swap macro and remove unnecessary variable *tmp_mem*.
>> This makes the code easier to read and maintain. Also, reduces the
>> stack usage.
>>
>> This code was detected with the help of Coccinelle.
>>
>> Signed-off-by: Gustavo A. R. Silva <gustavo at embeddedor.com>
>> ---
>>   drivers/gpu/drm/ttm/ttm_bo.c | 7 ++-----
>>   1 file changed, 2 insertions(+), 5 deletions(-)
>>
>> diff --git a/drivers/gpu/drm/ttm/ttm_bo.c b/drivers/gpu/drm/ttm/ttm_bo.c
>> index 5d8688e52..5142dcb 100644
>> --- a/drivers/gpu/drm/ttm/ttm_bo.c
>> +++ b/drivers/gpu/drm/ttm/ttm_bo.c
>> @@ -287,12 +287,9 @@ static int ttm_bo_handle_move_mem(struct ttm_buffer_object *bo,
>>   
>>   	if (ret) {
>>   		if (bdev->driver->move_notify) {
>> -			struct ttm_mem_reg tmp_mem = *mem;
>> -			*mem = bo->mem;
>> -			bo->mem = tmp_mem;
>> +			swap(*mem, bo->mem);
>>   			bdev->driver->move_notify(bo, false, mem);
>> -			bo->mem = *mem;
>> -			*mem = tmp_mem;
>> +			swap(*mem, bo->mem);
> This code assumes bo->mem is the same as tmp_mem after the call to
> move_notify. Is this always true?

Actually the old code assumed that. Using the swap macro now fixed that 
little unclean implementation.

Christian.

>
>
>
>>   		}
>>   
>>   		goto out_err;
>> -- 
>> 2.7.4
>>
>> _______________________________________________
>> dri-devel mailing list
>> dri-devel at lists.freedesktop.org
>> https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Flists.freedesktop.org%2Fmailman%2Flistinfo%2Fdri-devel&data=02%7C01%7Csyeh%40vmware.com%7C3bd79878de5141b5187408d5e6326e6d%7Cb39138ca3cee4b4aa4d6cd83d9dd62f0%7C1%7C0%7C636668026634710967&sdata=2raJ6TBpcEM5W7hi8iCEnrEdcfJa3W5ct3tF%2BlSZLkQ%3D&reserved=0



More information about the dri-devel mailing list