[PATCH V3 0/3] drm: replace magic numbers

Bjorn Helgaas helgaas at kernel.org
Tue Nov 12 17:35:00 UTC 2019


From: Bjorn Helgaas <bhelgaas at google.com>

amdgpu and radeon do a bit of mucking with the PCIe Link Control 2
register, some of it using hard-coded magic numbers.  The idea here is to
replace those with #defines.

Since v2:
  - Fix a gpu_cfg2 case in amdgpu/si.c that I had missed
  - Separate out the functional changes for better bisection (thanks,
    Michel!)
  - Add #defines in a patch by themselves (so a GPU revert wouldn't break
    other potential users)
  - Squash all the magic number -> #define changes into one patch

Since v1:
  - Add my signed-off-by and Alex's reviewed-by.

Bjorn Helgaas (3):
  PCI: Add #defines for Enter Compliance, Transmit Margin
  drm: correct Transmit Margin masks
  drm: replace numbers with PCI_EXP_LNKCTL2 definitions

 drivers/gpu/drm/amd/amdgpu/cik.c | 22 ++++++++++++++--------
 drivers/gpu/drm/amd/amdgpu/si.c  | 22 ++++++++++++++--------
 drivers/gpu/drm/radeon/cik.c     | 22 ++++++++++++++--------
 drivers/gpu/drm/radeon/si.c      | 22 ++++++++++++++--------
 include/uapi/linux/pci_regs.h    |  2 ++
 5 files changed, 58 insertions(+), 32 deletions(-)

-- 
2.24.0.rc1.363.gb1bccd3e3d-goog



More information about the dri-devel mailing list