[PATCH RFC v1 01/52] drm/crtc: Start renaming struct drm_crtc::dev to drm_dev

Uwe Kleine-König u.kleine-koenig at pengutronix.de
Wed Jul 12 09:46:11 UTC 2023


"dev" is usually used for struct device pointers. Using it for struct
drm_device pointers is irritating (for me at least). Introduce a
"drm_dev" as an alias with the intention to remove "dev" once all
drivers are adapted.

Signed-off-by: Uwe Kleine-König <u.kleine-koenig at pengutronix.de>
---
 include/drm/drm_crtc.h | 12 ++++++++++--
 1 file changed, 10 insertions(+), 2 deletions(-)

diff --git a/include/drm/drm_crtc.h b/include/drm/drm_crtc.h
index 8e1cbc75143e..66b65108024e 100644
--- a/include/drm/drm_crtc.h
+++ b/include/drm/drm_crtc.h
@@ -935,8 +935,16 @@ struct drm_crtc_funcs {
  * allows the CRTC to be controlled.
  */
 struct drm_crtc {
-	/** @dev: parent DRM device */
-	struct drm_device *dev;
+	/** @drm_dev: parent DRM device */
+	union {
+		/* "dev" is a name that is typically (only) used for struct
+		 * device pointers. It's about to be renamed to "drm_dev" to be
+		 * easier to parse for humans. To not have to convert all
+		 * drivers in a single step keep the old name around for now.
+		 */
+		struct drm_device *drm_dev;
+		struct drm_device *dev;
+	};
 	/** @port: OF node used by drm_of_find_possible_crtcs(). */
 	struct device_node *port;
 	/**
-- 
2.39.2



More information about the dri-devel mailing list