[FriBidi] Version 0.19.2 should be considered as new both API and ABI

Artyom artyomtnk at yahoo.com
Sun Oct 10 04:01:57 PDT 2010

> My personal opinion: just forget 0.10.x ever existed and fix  it to work
> with 0.19.x, that's what I did. Instead of checking which version  the
> user had, which was annoying, I just fixed everything to work only  with
> 0.19.x with the assumption that anyone who hasn't upgraded to  0.19.x
> won't upgrade my software either, and there's no reason why I  stay
> behind because of a few people who'll do this strange mix.

Actually many distros that provide stable version for long type
like Debian, RHEL, CentOS, Ubuntu LTS etc. would have the old
(and working well) version of fribidi. I don't want to force them
to upgrade if they don't want to.

There are also some other broken stuff like fribidi-config missing (that also
breaks my makefile, but this is a "small" issues)

Meanwhile I added the old 0.10.x version to the sources and make static build
and link till the issue would be solved or all major distros would move to 
version of fribidi.

(BTW My distro still provides 0.10.x - Debian Stable)



More information about the fribidi mailing list