<br><div><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;"><br>Looks great, although it's pretty hard to read:</blockquote><div><br><br>Attached as a file
<br><br></div><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;"><br>Agreed, except I don't like returning 0 for missing data -- that has<br>
bitten me in the ass several times (you can imagine how nice a 3D<br>terrain model looks like when some random points in the model have a<br>missing altitude value, and that's expressed with a zero...).<br></blockquote>
<div><br><br></div><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;"><br>> Do you see any good addition to the status enum? I was going to add a
<br>> bunch and then I though a human readable string would be better. The only<br>> ones I thought might be useful are. "No Service Available, No Position<br>> Available, Currently acquiring position.", are these useful to a program or
<br>> just the user? If it is useful to the program, then I would add, to the<br>> user then piggy back on the string message.<br></blockquote><div><br>I rethought status and here's what I think is better.<br><br>
A set of flags. bit packed into a int.<br><br>0 No Service available<br>1 currently acquiring Altitude<br>2 currently acquiring Long<br>4 currently acquiring Lat<br>8 Altitude Available<br>16 Long Available<br>32 Lat Available
<br><br>This would solve the hostip altitude probem it could have a status (48) meaning only lat and long are valid. So technically you would<br><br>call init<br>call status<br>call position<br><br>hook up signal to position and status to find when things changed.
<br> </div><br><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;"><br>> I've been thinking now that we should add a "position_hint" input to the API
<br>> for use in auto submitting your position to Host IP. There could be some<br>> kind of configuration for privacy in geoclue master. I wonder if this could<br>> be generic for more API. I know you can do assisted GPS. is there a good
<br>> way to add this too?<br><br>I'm undecided on the data submission issue... I'd probably put the<br>submission in a separate program.<br><br>I fully agree on the privacy config: there should be geoclue-wide
<br>position privacy settings that geoclue _and_ applications can use.<br>Although it might not be a top priority just yet, this will be very<br>important when our position data starts to escape to the internet (like<br>with the Gajim XEP-0080-implementation). Speaking of which, we probably
<br>should follow and take part in xmpp/XEP work in that area.</blockquote><div><br>I think privacy is an issues, but we shouldn't let it affect our api too much. It should a UI type configuration setting.<br>I won't put it in now. I guess it wouldn't be hard for the hostapi to put it's own listen into itself.
<br><br>Keith Preston<br><br></div></div><br>