[gstreamer-bugs] [Bug 319784] New: mad claims to need more data

GStreamer (bugzilla.gnome.org) bugzilla-daemon at bugzilla.gnome.org
Tue Oct 25 13:29:36 PDT 2005

Do not reply to this via email (we are currently unable to handle email
responses and they get discarded).  You can add comments to this bug at
 GStreamer | gst-plugins-ugly | Ver: HEAD CVS

           Summary: mad claims to need more data
           Product: GStreamer
           Version: HEAD CVS
          Platform: Other
        OS/Version: All
            Status: UNCONFIRMED
          Severity: normal
          Priority: Normal
         Component: gst-plugins-ugly
        AssignedTo: gstreamer-bugs at lists.sourceforge.net
        ReportedBy: luogni at tin.it
         QAContact: gstreamer-bugs at lists.sourceforge.net
                CC: all-bugs at bugzilla.gnome.org

Please describe the problem:
Sometimes when playing a video (avi/mpeg4/mp3) totem tells me that it cannot
decode the stream, looking at the GST_DEBUG=*:3 log i can see:

WARN  (0x83310f0 - 0:00:17.696434000)                  mad(18657)
gstmad.c(1283):gst_mad_chain:<mad0> error: mad claims to need more data than
7701 bytes, we don't have that much
INFO  (0x83310f0 - 0:00:18.607176000)     GST_ERROR_SYSTEM(18657)
gstelement.c(1467):gst_element_message_full:<mad0> posting message: Impossibile
decodificare lo stream.

(Impossibile decodificare lo stream = Impossible to decode the stream)

two things:
- it happens only with totem, using playbin from command line works fine
- it happens only sometimes. Others time totem just hangs

I'm using current cvs as of 2005/10/25 19:00 CET and totem head cvs with the
latest 0.9 patch.

Steps to reproduce:
1. Play a file with totem

Actual results:

Expected results:

Does this happen every time?

Other information:

------- You are receiving this mail because: -------
You are the assignee for the bug.
You are the QA contact for the bug.

More information about the Gstreamer-bugs mailing list