[gstreamer-bugs] [Bug 500142] New: switch element in switch plugin should be renamed
bugzilla-daemon at bugzilla.gnome.org
Tue Nov 27 23:54:36 PST 2007
If you have any questions why you received this email, please see the text at
the end of this email. Replies to this email are NOT read, please see the text
at the end of this email. You can add comments to this bug at:
GStreamer | gst-plugins-bad | Ver: HEAD CVS
Summary: switch element in switch plugin should be renamed
Version: HEAD CVS
AssignedTo: gstreamer-bugs at lists.sourceforge.net
ReportedBy: ensonic at sonicpulse.de
QAContact: gstreamer-bugs at lists.sourceforge.net
GNOME version: Unspecified
GNOME milestone: Unspecified
the switch element in bad is infact a "N-to-1 input switch" (as also the
gst-inspect tells). It would be good to rename the element in oder to also be
able to add a "1-to-N output switch" to the same plugin.
So what would be a good element name?
* input-switch (still ambigous)
* input-select (makes clear that it selects 1 of N inputs)
See http://bugzilla.gnome.org/page.cgi?id=email.html for more info about why you received
this email, why you can't respond via email, how to stop receiving
emails (or reduce the number you receive), and how to contact someone
if you are having problems with the system.
You can add comments to this bug at http://bugzilla.gnome.org/show_bug.cgi?id=500142.
More information about the Gstreamer-bugs