[gstreamer-bugs] [Bug 616814] Photography interface extension

GStreamer (bugzilla.gnome.org) bugzilla at gnome.org
Tue Apr 27 03:23:52 PDT 2010


https://bugzilla.gnome.org/show_bug.cgi?id=616814
  GStreamer | gst-plugins-bad | git

--- Comment #6 from Stefan Kost (gstreamer, gtkdoc dev) <ensonic at sonicpulse.de> 2010-04-27 10:23:48 UTC ---
(In reply to comment #5)
> Emboss and sketech are not related to the color tone mode. I will delete them
> from the color tone mode.
Thanks.

> 
> The noise reduction functions are not posprocessing effects. They can be turned
> on/off in the ISP and take effect during the image capture. I think it will be
> better to add them to the photography interface as they are the settings to the
> image capture.

I understand. The question here is how to agree on the canonical algorithm
names. I am just a bit worried that the specific noise reduction algorithms
don't map easily accross ISP. Also please reconsider the names:

typedef enum
 {
  GST_PHOTOGRAPHY_NOISE_REDUCTION_MODE_BAYER = ( 1<<0 ),
  GST_PHOTOGRAPHY_NOISE_REDUCTION_MODE_YCC = ( 1<<1 ),
  GST_PHOTOGRAPHY_NOISE_REDUCTION_MODE_TEMPORAL= ( 1<< 2),
  GST_PHOTOGRAPHY_NOISE_REDUCTION_MODE_FPN = (1 << 3),
  GST_PHOTOGRAPHY_NOISE_REDUCTION_MODE_EXTRA = (1 << 4)
} GstNoiseReductionMode;

what about:
typedef enum
 {
  GST_PHOTOGRAPHY_NOISE_REDUCTION_BAYER = ( 1<<0 ),
  GST_PHOTOGRAPHY_NOISE_REDUCTION_YCC = ( 1<<1 ),
  GST_PHOTOGRAPHY_NOISE_REDUCTION_TEMPORAL= ( 1<< 2),
  GST_PHOTOGRAPHY_NOISE_REDUCTION_FPN = (1 << 3),
  GST_PHOTOGRAPHY_NOISE_REDUCTION_EXTRA = (1 << 4)
} GstPhotographyNoiseReduction;
(the typename should match the enum names)

Please also add a doc blob describing it briefly each one. E.g. FPN and EXTRA
sounds unclear (do you have better names for them).

-- 
Configure bugmail: https://bugzilla.gnome.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.
You are the assignee for the bug.




More information about the Gstreamer-bugs mailing list