[Bug 606287] Add an 'is-vbr' boolean tag
bugzilla at gnome.org
Mon Feb 28 20:22:03 PST 2011
GStreamer | gstreamer (core) | unspecified
--- Comment #6 from Arun Raghavan <arun at accosted.net> 2011-03-01 04:21:56 UTC ---
(In reply to comment #5)
> (In reply to comment #4)
> > Wouldn't IS_VBR be a better name for this?
> I think a stream "has a variable bitrate".
Or "is a variable bitrate stream". Both are identical as far as I am concerned,
> I was wondering earlier if we would need a probability or a string like "cbr,
> maybe-cbr, unknown, maybe-vbr, vbr". But that's ugly :/
Which is why this patch hasn't been pushed so far.
We could retain the current tag name and replace the "guaranteed" to "most
probably" with a big caveat in the documentation about the accuracy of this
tag. I think this is an uncertainty that we will have to live with since the
only definitive way to determine this (parse the whole stream) is not likely to
be practical in most cases.
Configure bugmail: https://bugzilla.gnome.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.
You are the assignee for the bug.
More information about the gstreamer-bugs