[Bug 703486] Implement GstNavigation interface in glimagesink

GStreamer (bugzilla.gnome.org) bugzilla at gnome.org
Wed Jul 23 20:14:26 PDT 2014


https://bugzilla.gnome.org/show_bug.cgi?id=703486
  GStreamer | gst-plugins-gl | git

Matthew Waters <ystreet00> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #280037|none                        |needs-work
             status|                            |

--- Comment #27 from Matthew Waters <ystreet00 at gmail.com> 2014-07-24 03:14:21 UTC ---
Review of attachment 280037:
 --> (https://bugzilla.gnome.org/review?bug=703486&attachment=280037)

I like the sound of get_surface_dimensions marginally better.  Various other
API's are also transitioning towards the surface naming convention as well.

::: ext/gl/gstglimagesink.c
@@ +203,3 @@
+    event = gst_event_new_navigation (structure);
+
+    window_class->get_window_dimensions (window, &width, &height);

Should use a public GstGLWindow function instead of the vfunc.  Will also need
to check that the returned values are somewhat valid if the GstGLWindow
subclass does not implement that function.

::: gst-libs/gst/gl/gstglwindow.h
@@ +151,3 @@
 guintptr gst_gl_window_get_display          (GstGLWindow *window);

+

Spurious new line

-- 
Configure bugmail: https://bugzilla.gnome.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.
You are the assignee for the bug.


More information about the gstreamer-bugs mailing list