[Bug 738608] Add URI handler to hlssink

GStreamer (bugzilla.gnome.org) bugzilla at gnome.org
Mon Oct 20 01:24:06 PDT 2014


https://bugzilla.gnome.org/show_bug.cgi?id=738608
  GStreamer | gst-plugins-bad | 1.4.3

Thiago Sousa Santos <thiagossantos> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #288651|none                        |needs-work
             status|                            |

--- Comment #2 from Thiago Sousa Santos <thiagossantos at gmail.com> 2014-10-20 08:24:01 UTC ---
Review of attachment 288651:
 --> (https://bugzilla.gnome.org/review?bug=738608&attachment=288651)

Aside the naming issues we need to decide if we want another custom scheme into
gstreamer. We already have v4l2 for example, but that was because there was no
way to inject a non uri handler element into it. What's the use case here?

::: configure.ac
@@ +3000,3 @@
+  PKG_CHECK_MODULES(SOUP2, libsoup-2.4 >= 2.38.1, HAVE_SOUP2="yes", [
+      HAVE_SOUP2="no"
+    ])

I'm concerned whether this would end up disabling hls support in non-linux
platforms. Is libsoup easily instalable?

::: ext/hls/gsthlssink.c
@@ +90,3 @@
 gst_hls_sink_change_state (GstElement * element, GstStateChange trans);
 static gboolean schedule_next_key_unit (GstHlsSink * sink);
+static void gst_barco_parse_uri (GObject * obj, SoupURI * uri);

Cool name but I guess it wasn't intentional

@@ +606,3 @@
+
+static gboolean
+

Same naming issue here

@@ +623,3 @@
+
+static void
+  return TRUE;

And here

-- 
Configure bugmail: https://bugzilla.gnome.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.
You are the assignee for the bug.


More information about the gstreamer-bugs mailing list