[gst-devel] configure question

Erik Walthinsen omega at temple-baptist.com
Mon May 28 19:59:01 CEST 2001

On Mon, 28 May 2001, Thomas Vander Stichele wrote:

> Here's what I got with today's CVS in my regular CVS build dir :
> checking for ALSA CFLAGS...
> checking for ALSA LDFLAGS...  -lasound -lm -ldl
> checking for libasound headers version >= 0.9.0... not present.
> configure: error: Sufficiently new version of libasound not found.
> and it ends on that note.
> So I suppose something changed with ALSA stuff, even though it never
> complained before and I don't use ALSA anyway.
> Is ALSA considered "core" (ie should I upgrade alsa without using it) or
> should the check failure be less fatal ?

The problem is that the alsasink is incompatible with alsa 0.9.0, so I
added a check that made it not compile in that case.  As soon as the
alsasink is upgraded to 0.9.x compliance (and preferrably with
back-support, somehow), we'll change that to match.

      Erik Walthinsen <omega at temple-baptist.com> - System Administrator
       /  \                GStreamer - The only way to stream!
      |    | M E G A        ***** http://gstreamer.net/ *****
      _\  /_

More information about the gstreamer-devel mailing list