[gst-devel] going over GstPad ...
Thomas Vander Stichele
thomas at urgent.rug.ac.be
Sun Sep 1 10:07:13 CEST 2002
I did a few things :
a) clean up code and docs (yay)
b) make all creation functions take NULL as a name so that you get
a guaranteed unique name if you give NULL
c) gst_pad_set_parent took a gstobject, and _get_parent returned a
I changed the first to take a gstobject.
(I couldn't find any instance of gst_pad_set_parent in the code
though, except for three in one of the avi plug-ins)
Here are some more things I considered doing and would like input on :
a) gst_pad_load_and_connect (xmlNodePtr self, GstObject *parent)
only applies to GstElements, why does it accept GstObject ?
Can I change this ?
b) I would like to rename
to be in line with the rest of the functions.
Also, this function has the following prototype
gst_pad_ghost_save_thyself (GstPad *pad,
but the bin isn't used in this function. Shall I drop that argument ?
c) some of the enum types are not fully described in the gstpad.sgml
The other changes will be committed shortly.
The Dave/Dina Project : future TV today ! - http://davedina.apestaart.org/
Are you happy where you're sleeping ?
Does he keep you safe and warm ?
Does he tell you when you're sorry ?
Does he tell you when you're wrong ?
<-*- thomas at apestaart.org -*->
URGent, the best radio on the Internet - 24/7 ! - http://urgent.rug.ac.be/
More information about the gstreamer-devel