[gst-devel] problematic pipeline

Benjamin Otte in7y118 at public.uni-hamburg.de
Fri Dec 12 05:40:00 CET 2003


On Fri, 12 Dec 2003, Martin Soto wrote:

> At least since the new parsing code is in, you cannot specify pads as
> "video_%d".  The new syntax also seems to require that you name elements
> explicitly. I cannot test right now (I'm at work) but I guess something
> like this is fine for what you need:
>
You need to specify SOMETIMES pads by their real name. REQUEST pads are
still requested by padtemplate name ("ugh", i know).

Explicit naming is the only thing guaranteed to work. GStreamer is free to
chose any name for an element. Currently it will chose elementname$nr,
just like before, but that may change.

> gst-launch filesrc location=alien.mpg !
> mpegdemux name=demux demux.video_00!
> {queue ! md5sink } demux.audio_00! { queue ! fakesink }
>
This looks correct. I'd put a space between the pad reference and the
exclamation mark however for readability. And I'd group pipeline parts
inside the threads for readability. Like this:
gst-launch filesrc location=alien.mpg ! mpegdemux name=demux
{ demux.video_00 ! queue ! md5sink } { demux.audio_00 ! queue ! fakesink }

And if you don't need the naming guarantees and just hack it into bash,
this should work, too:
gst-launch filesrc location=alien.mpg ! mpegdemux .video_00 ! { queue !
md5sink } { mpegdemux0.audio_00 ! queue ! fakesink }





More information about the gstreamer-devel mailing list