[gst-devel] good point from gnomedesktop
Thomas Vander Stichele
thomas at urgent.rug.ac.be
Wed Jan 8 09:38:02 CET 2003
> Yes this is a problem. Which is why I've been moaning about it for a a
> long time. ;) See the post and discussion from a while ago for possible
> alternative names. We need to rename disconnect too. Only reason I
> haven't done the switch myself is I can't decide what name to use.
> Tradeoff's between verbose long names and names so short they are as bad
> and generic as g_object_connect().
Ok, then we need to fix it really soon :)
> I wouldn't bother with API-compatible stuff, just drop the old API and
> let people fix their code. It's not a complex change.
No, I'm going to add compat stuff, preferably in a new header file.
It's a practice we should adopt really soon, and _connect functions are in
every gst app, so it's necessary.
Even the pad_query change was frowned upon from gnome and it only broke
gnome-media for about an hour :)
> I assume most people want short names. I'd suggest the following. Keep
> the _to_/_from_ part for consistancy in the API though it's not needed
> to solve this problem for other than _[dis]connect():
My idea is to change connect to chain. I like it, it's shorter, and it
makes sense. so ...
_connect -> _chain
_connect_many -> _chain_many
_connect_filtered -> _chain_filtered
_disconnect -> _unchain_from
_disconnect_many -> _unchain_many
I don't mind getting these functions that bit shorter :) I don't want them
to end up longer.
What does everyone think ? I'd like a quick decision, because the API
stuff is something I'd like to see happen for obvious reasons.
The Dave/Dina Project : future TV today ! - http://davedina.apestaart.org/
<-*- thomas (dot) apestaart (dot) org -*->
I was about to have my first sexual experience
and I wasn't even one of the players...
<-*- thomas (at) apestaart (dot) org -*->
URGent, the best radio on the Internet - 24/7 ! - http://urgent.rug.ac.be/
More information about the gstreamer-devel