[gst-devel] RE: elegancy (was: RE: win32 build works fine)
Marc_VanDaele at Jabil.com
Fri Jun 18 06:10:17 CEST 2004
Thanks again for your constructive clarification.
The distinction between elegant for the customer and elegant for the
developer is indeed a useful one and I agree with your priorities.
Wouldn't it be possible to remove GST_CAT_DEFAULT *variable*.
Having both a variable and a define with the same name is confusing.
If I understand it correctly, the variable comes into play whenever a user
did not have the two lines
#define GST_CAT_DEFAULT debug_scheduler
I have no overview of the complete gstreamer software stack but does this
happen often? I would assume it doesn't.
By removing the variable, I guess the user will get a compiler error and
will have to add the two lines above (or similar); no big deal, IMO, and it
removes the ambiguity between the variable and the define.
Looking forward to your opinion,
More information about the gstreamer-devel