[gst-devel] Bumping the GLib requirement to GLib-2.12?
Thomas Vander Stichele
thomas at apestaart.org
Tue Dec 18 11:05:39 CET 2007
On Mon, 2007-12-17 at 21:36 +0100, Sebastian Dröge wrote:
> Am Montag, den 17.12.2007, 17:05 +0100 schrieb Thomas Vander Stichele:
> > On Fri, 2007-12-14 at 11:04 +0000, Tim Müller wrote:
> > > Hi,
> > >
> > > currently GStreamer requires only GLib 2.8, which was released in
> > > mid-2005.
> > >
> > > I think it would be nice if we could bump our GLib requirement to
> > > something slightly more current so we can make use of all the new APIs
> > > that were added in the last two years.
> > >
> > > My suggestion is to bump the requirement to GLib 2.12, which was
> > > released in mid-2006.
> > >
> > > This requirement would be met by ubuntu edgy/feisty/gutsy, debian
> > > stable/testing/sid and Fedora Core 6 upwards, and seems to me like a
> > > good compromise between bleeding edge and completely outdated.
> > We're still tied heavily to fc5, so I would appreciate still working
> > against that.
> > We could roll in a newer glib package in the next testing cycle we have
> > though, which would be within the next 2-3 months.
> 2-3 months sounds ok... would it be possible to drop all the ugly parser
> hacks and require flex >= 2.5.31 and bison >= 1.875 then while we're at
> it? :)
is bison 2.1 and flex 2.5.4a ok ?
And you couldn't tell the difference
Between me and you
And I nearly didn't notice
The gentlest feeling
Elisa - future TV today !
More information about the gstreamer-devel