[gst-devel] failure: no device event controller found.

Tim Müller t.i.m at zen.co.uk
Wed Nov 7 10:16:28 CET 2007

On Tue, 2007-11-06 at 11:28 +0100, Tomas KRAMAR wrote:


> atk-bridge-WARNING **: failure: no device event controller found.
> sh: jackd: not found
> We managed to resolve the second error by installing jackd package,

It's not GStreamer that outputs this message if jackd isn't installed.
You could file a bug report with your distro if it annoys you too much.

> (...) but the first problem remains.
> Why are we getting this message? Is there some package gstreamer
> depends on, but which is not installed?

Don't think I have ever seen that message.  It doesn't look
GStreamer-related to me.  Maybe it's GUI-related? (ATK is the
accessibility toolkit Gtk/Gnome use).  Best to ask the usual support
channels/forums for that user's distro IMO.

You could also ask the user to run your application in a debugger with
G_DEBUG=fatal_warnings, then it will break at the line of code that
prints the warning and you can look at the stack trace and get a better
idea where it comes from and maybe even what causes it.


More information about the gstreamer-devel mailing list