[gst-devel] issue in playing video

V.Murugadoss v.murugadoss at gdatech.co.in
Tue Nov 4 19:16:42 CET 2008

Hi fabioestevam,
Thanks for the reply. Now i am getting all the 6 plugins. When i play a
mpeg or avi file using the commands u mentioned in previous mail, it
displays a message
mfw_vpudecoder is not found (exact message i send u in previous mail)

Can u please say, how to solve it

> --- On Tue, 11/4/08, murugadoss <v.murugadoss at gdatech.co.in> wrote:
>> From: murugadoss <v.murugadoss at gdatech.co.in>
>> Subject: Re: [gst-devel] issue in playing video
>> To: fabioestevam at yahoo.com, "Discussion of the development of GStreamer"
>> <gstreamer-devel at lists.sourceforge.net>
>> Date: Tuesday, November 4, 2008, 12:19 PM
>> Hi fabio,
>> I am using* 20070522* package,  as said in the document,
>> compiled the
>> files. When i check with *gst-inspect | grep mfw*, i get
>> only 4 packages
>> to be installed, i get *mfw_vpudec, mfw_enc, mfw_v4lsrc,
>> mfw_v4lsink*,
>> but i am not getting *mfw_avidemuxer and mfw_mp4demuxer
>> *package. I have
>> exported *LD_library_path and gst_plugin_path.* i can find
>> the packages
>> in ../*usr/lib/gstreamer-0.10/*  folder.
>> Can u say me, how to add these plugins?
>> Thanks for the reply
> Maybe it is easier if you just use the pre-build plugins that are part of
> the package.
> Follow section 7.1 (Using the pre-built Plugins) of the release notes
> document:
> - Copy all the content of fsl_codecs/libs to ../rootfs/home in the i.MX27
> file system
> - Boot Linux on the i.MX27
> - Set the following variables on the i.MX27ADS Linux:
> export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/home/codec:/home/parser
> export GST_PLUGIN_PATH=$GST_PLUGIN_PATH:/home/plugin
> After doing this, gst-inspect | grep mfw should list 6 elements.

More information about the gstreamer-devel mailing list