[PATCH] Getter for the powersave state

David Zeuthen david at fubar.dk
Tue Nov 28 10:44:51 PST 2006


Oh, turns out I was confused and thought you meant this was for CPU
Frequency Control; didn't realize you meant SetPowerSave() on the
org.fd.Hal.D. SystemPowerManagement interface. 

Probably a property to do this is fine though Danny's comments still
makes sense, e.g. 

 1. Fix up the docs with s/is saving power/last value passed to

 2. Rename property to
    (I'm open for a better name than last_value_passed_to_set_power_save
    but is_powersaving isn't accurated enough. Need input.)

Sorry again for the confusion.


More information about the hal mailing list