fseidel at suse.de
Mon Mar 12 06:09:16 PDT 2007
On Monday 12 March 2007 00:21:43 Richard Hughes wrote:
> As for "safe suspend", it is really safer than suspend, as the usual
> warnings about "if the battery runs out your work is lost" don't
Well, this also applies for normal hibernate, but i guess you wouldn't
propose to rename hibernate to (e.g.) "slow'n'safe suspend", would you?
In my opinion there are some good reasons to name (at least some) things
different for developers than for users (-interface).
While for users it might be enough to have a rough notion what this or
that option will do, developers need a clear and straightforward
interface with straightforward names that are to be precise and
consitent (while "fancy" names shouldn't be used inside an abstractin
layer.. in my opinion).
So, i vote for using
(or at least for..
.. instead of "safe suspend")
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Size: 189 bytes
Desc: not available
Url : http://lists.freedesktop.org/archives/hal/attachments/20070312/df93739e/attachment.pgp
More information about the hal