[immodule-qt] Slave qt immodule support and dead key issue
liucougar at gmail.com
Sun Jul 18 03:57:45 EEST 2004
On Sun, 18 Jul 2004 09:45:21 +0900, YamaKen <yamaken at bp.iij4u.or.jp> wrote:
> There are two different names with different responsibility in
> the input method world as below, but I think that the
> responsibility of QInputContext::name() was not explained enough
> and the name is inappropriate.
> - Display name
> The name for endusers appeared in a menu and so on. It should
> be translated according to the locale as i18n string. In our
> implementation, QInputContextPlugin::displayName() is a this
> - Identifier name (canonical name)
> The name to identify and specify input methods for the
> switching mechanism and so on. I think that
> QInputContext::inputMethodName() must be it and has to be
> consistent with QInputContextPlugin::keys(). We should
> explicitly describe this constraint into the document. I also
> think that it should be QCString rather than QString to avoid
> using i18n string for this and confusing this with display
> We have to determine whether following issues are appropriate or
> not. Anyone, please tell me your opinion.
> - QInputContext::inputMethodName() is a identifier name
> - The name has to be consistent with other functions such as
> - The name for a input method should be consistent with the name
> appeared in other immodule-like frameworks as 'canonical name'
> to help desktop-wide IM-switching
> e.g.) use the single name "uim-anthy" for qt-immodule,
> gtk-immodule and so on for the uim-anthy input method
Agree completely with all the above
> And we also have to define appropriate function names for each
> following domains. I suggest displayName() and identifierName()
> from the point of view of roles.
These two seem fine to me
> I also have a question about the names in the IIIMF. IIIMF has
> the term 'human readable name' and 'idname'. Does it
> corresponding to the two names described as above?
I have little idea about IIIMF. However if it is the case just as you
thought, then we may adopt the names defined in IIIMF...
More information about the immodule-qt