[Intel-gfx] Problem with intel 855gm graphics

Zhenyu Wang zhenyu.z.wang at intel.com
Thu Mar 26 08:40:50 CET 2009


On 2009.03.26 15:31:40 +0800, Gregor Fuis wrote:
> Hi guys,
> 
> I have a problem with intel 855gm graphich on ubuntu 9.04 which uses
> intel 2.6.3 driver. It wont detect my monitor connected on LVDS
> output. I also tried it with ubuntu 8.04 whic uses intel 2.2.1 and
> here it works great, but I would need the latest software from Ubuntu
> 9.04.
> 
> Here is part of log where detection is going on in 9.04:
> 
> [    1.041300] (II) intel(0): EDID for output VGA
> [    1.041360] (II) intel(0): Output VGA disconnected
> [    1.041385] (WW) intel(0): No outputs definitely connected, trying again...
> [    1.041404] (II) intel(0): Output VGA disconnected
> [    1.041427] (WW) intel(0): Unable to find initial modes
> [    1.041448] (EE) intel(0): No valid modes.
> 

This should be caused by my LVDS detect patch, X log with ModeDebug on?
Or you may test with src/reg_dumper/intel_lid program to check lid status.

It looks acpi button is broken badly on older machines, and I think we might be
the first one to use this interface to trigger this acpi problem explicitly.
We might ignore the detect for pre-9xx chips...

-- 
Open Source Technology Center, Intel ltd.

$gpg --keyserver wwwkeys.pgp.net --recv-keys 4D781827
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 197 bytes
Desc: Digital signature
URL: <http://lists.freedesktop.org/archives/intel-gfx/attachments/20090326/77570da9/attachment.pgp>


More information about the Intel-gfx mailing list