[Intel-gfx] [PATCH 14/14] drm/i915: inline enable/disable_irq into ring->get/put_irq

Ben Widawsky ben at bwidawsk.net
Fri Apr 13 03:03:30 CEST 2012


On Wed, 11 Apr 2012 22:12:59 +0200
Daniel Vetter <daniel.vetter at ffwll.ch> wrote:

> Now that these are properly refactored this additional indirection
> doesn't really buy us anything but confusion. Hence inline them.
> 
> This duplicates the ironlake gt enable/disable code snippet, but we've
> already separate ilk from gen6+ gt irq in i915_irq.c, so I think this
> makes more sense.
> 
> Signed-Off-by: Daniel Vetter <daniel.vetter at ffwll.ch>

Bikeshed:
While doing all this, I think put/get irq is really terribly named. I
was a much bigger fan of the enable disable.

Also, you could use a bit of flow control to write to the correct IMR
register and not duplicate functions at all. You already do the
POSTING_READ so performance shouldn't matter.

Something like...

uint32_t imr = GEN(dev) >= 5 ? GTIMR: IMR;




More information about the Intel-gfx mailing list