[Intel-gfx] [PATCH 1/3] drm/i915: make DP configuration vars less confusing in ironlake_crtc_mode_se
chris at chris-wilson.co.uk
Tue Apr 10 14:22:09 PDT 2012
On Tue, 10 Apr 2012 11:58:03 -0700, Jesse Barnes <jbarnes at virtuousgeek.org> wrote:
> Both PCH and CPU eDP are DP, so set the is_dp flag to true. Add
> is_cpu_edp and is_pch_edp bools to make checking for each less verbose
> (rather than has_edp_encoder && !intel_encoder_is_pch_edp() sprinkled
> everywhere). And rename the "has_edp_encoder" variable to just
> With the above variables cleaned up, the rest of the code becomes a bit
> more readable and clear.
> Signed-off-by: Jesse Barnes <jbarnes at virtuousgeek.org>
Ok, that took quite a bit of reading to be sure that the changes were
consistent. Unfortunately it also looks to be in its simplest form.
Reviewed-by: Chris Wilson <chris at chris-wilson.co.uk>
Chris Wilson, Intel Open Source Technology Centre
More information about the Intel-gfx