[Intel-gfx] [PATCH 1/3] drm/i915: make DP configuration vars less confusing in ironlake_crtc_mode_se
daniel at ffwll.ch
Wed Apr 11 02:53:55 PDT 2012
On Tue, Apr 10, 2012 at 10:22:09PM +0100, Chris Wilson wrote:
> On Tue, 10 Apr 2012 11:58:03 -0700, Jesse Barnes <jbarnes at virtuousgeek.org> wrote:
> > Both PCH and CPU eDP are DP, so set the is_dp flag to true. Add
> > is_cpu_edp and is_pch_edp bools to make checking for each less verbose
> > (rather than has_edp_encoder && !intel_encoder_is_pch_edp() sprinkled
> > everywhere). And rename the "has_edp_encoder" variable to just
> > "edp_encoder".
> > With the above variables cleaned up, the rest of the code becomes a bit
> > more readable and clear.
> > Signed-off-by: Jesse Barnes <jbarnes at virtuousgeek.org>
> Ok, that took quite a bit of reading to be sure that the changes were
> consistent. Unfortunately it also looks to be in its simplest form.
> Reviewed-by: Chris Wilson <chris at chris-wilson.co.uk>
Queued for -next, thanks for the patch. I don't know what to do with the
other two patches, are they supposed to be for -fixes?
Mail: daniel at ffwll.ch
Mobile: +41 (0)79 365 57 48
More information about the Intel-gfx