[Intel-gfx] [PATCH v.2 03/12] DRM/i915: Convert HPD interrupts to make use of HPD pin assignment in encoders.

Chris Wilson chris at chris-wilson.co.uk
Thu Feb 28 01:12:33 CET 2013


On Mon, Feb 25, 2013 at 12:06:50PM -0500, Egbert Eich wrote:
> This allows to enable HPD interrupts for individual pins to only receive
> hotplug events from lines which are connected and working.
> 
> Signed-off-by: Egbert Eich <eich at suse.de>
> ---
>  drivers/gpu/drm/i915/i915_irq.c |  160 ++++++++++++++++++++++++--------------
>  drivers/gpu/drm/i915/i915_reg.h |   32 ++++++++-
>  2 files changed, 132 insertions(+), 60 deletions(-)
> 
> diff --git a/drivers/gpu/drm/i915/i915_irq.c b/drivers/gpu/drm/i915/i915_irq.c
> index 5fd3267..306cd79 100644
> --- a/drivers/gpu/drm/i915/i915_irq.c
> +++ b/drivers/gpu/drm/i915/i915_irq.c
> @@ -36,6 +36,68 @@
>  #include "i915_trace.h"
>  #include "intel_drv.h"
>  
> +static const u32 hpd_ibx[] = {
> +	0, /* HPD_NONE */
> +	SDE_CRT_HOTPLUG, /* HPD_CRT */
> +	SDE_SDVOB_HOTPLUG, /* HPD_SDVO_B */
> +	0, /* HPD_SDVO_C */
> +	SDE_PORTB_HOTPLUG, /* HPD_PORT_B */
> +	SDE_PORTC_HOTPLUG, /* HPD_PORT_C */
> +	SDE_PORTD_HOTPLUG  /* HPD_PORT_D */
> +};

Trivial bikeshed, these would look neater as
  static const u32 hpd_ibx[] = {
	[HPD_CRT] = SDE_CRTC_HOTPLUG,
	[HPD_SDVO_B] = SDE_SDVOB_HOTPLUG,
	[HPD_PORT_B] = SDE_PORTB_HOTPLUG,
	[HPD_PORT_C] = SDE_PORTC_HOTPLUG,
	[HPD_PORT_D] = SDE_PORTD_HOTPLUG,
  };
-Chris

-- 
Chris Wilson, Intel Open Source Technology Centre



More information about the Intel-gfx mailing list