[Intel-gfx] [PATCH 0/4] Refactor the code storing the reason why we disable FBC
Damien Lespiau
damien.lespiau at intel.com
Thu Feb 26 17:30:56 PST 2015
There was a bit of duplicated logic here and we can have easier code to deal
with when adding a reason why we decided to disable FBC: we don't need to add
an enum, change the debugfs logic and code the check (3 sites), we can just
code the check (1 site).
That also removes 50 lines of code, which is always a happy event.
--
Damien
--
Damien Lespiau (4):
drm/i915: Refactor where we display the reason to disable FBC
drm/i915: Use the original FBC reason strings in debugfs
drm/i915: Remove the no FBC reason enum
drm/i915: Rename no_fbc_str to no_fbc_reason
drivers/gpu/drm/i915/i915_debugfs.c | 50 +++++++------------------------------
drivers/gpu/drm/i915/i915_drv.h | 14 +----------
drivers/gpu/drm/i915/intel_fbc.c | 45 +++++++++++++--------------------
3 files changed, 28 insertions(+), 81 deletions(-)
--
1.8.3.1
More information about the Intel-gfx
mailing list