[PATCH 2/6] drm/i915/dp: Add TCON HDR capability checks

Kandpal, Suraj suraj.kandpal at intel.com
Tue Apr 23 04:09:01 UTC 2024



> -----Original Message-----
> From: Murthy, Arun R <arun.r.murthy at intel.com>
> Sent: Tuesday, April 23, 2024 8:25 AM
> To: Kandpal, Suraj <suraj.kandpal at intel.com>; intel-gfx at lists.freedesktop.org
> Cc: Borah, Chaitanya Kumar <chaitanya.kumar.borah at intel.com>; Shankar,
> Uma <uma.shankar at intel.com>; Nautiyal, Ankit K
> <ankit.k.nautiyal at intel.com>; Kumar, Naveen1 <naveen1.kumar at intel.com>;
> sebastian.wick at redhat.com
> Subject: RE: [PATCH 2/6] drm/i915/dp: Add TCON HDR capability checks
> 
> 
> > -----Original Message-----
> > From: Kandpal, Suraj <suraj.kandpal at intel.com>
> > Sent: Monday, April 22, 2024 9:03 AM
> > To: intel-gfx at lists.freedesktop.org
> > Cc: Borah, Chaitanya Kumar <chaitanya.kumar.borah at intel.com>; Shankar,
> > Uma <uma.shankar at intel.com>; Nautiyal, Ankit K
> > <ankit.k.nautiyal at intel.com>; Murthy, Arun R
> > <arun.r.murthy at intel.com>; Kumar, Naveen1 <naveen1.kumar at intel.com>;
> > sebastian.wick at redhat.com; Kandpal, Suraj <suraj.kandpal at intel.com>
> > Subject: [PATCH 2/6] drm/i915/dp: Add TCON HDR capability checks
> >
> > Add checks to see the HDR capability of TCON panel.
> >
> > Signed-off-by: Suraj Kandpal <suraj.kandpal at intel.com>
> > ---
> >  drivers/gpu/drm/i915/display/intel_display_types.h    |  5 +++++
> >  drivers/gpu/drm/i915/display/intel_dp_aux_backlight.c | 10 ++++++++++
> >  2 files changed, 15 insertions(+)
> >
> > diff --git a/drivers/gpu/drm/i915/display/intel_display_types.h
> > b/drivers/gpu/drm/i915/display/intel_display_types.h
> > index 62f7a30c37dc..1cf4caf1a0a9 100644
> > --- a/drivers/gpu/drm/i915/display/intel_display_types.h
> > +++ b/drivers/gpu/drm/i915/display/intel_display_types.h
> > @@ -401,6 +401,11 @@ struct intel_panel {
> >  			} vesa;
> >  			struct {
> >  				bool sdr_uses_aux;
> > +				bool supports_2084_decode;
> > +				bool supports_2020_gamut;
> > +				bool supports_segmented_backlight;
> > +				bool supports_sdp_colorimetry;
> > +				bool supports_tone_mapping;
> >
> 		} intel;
> Even though not part of this patch, but the struct is growing.
> Can you change the name of this struct to a meaningful one, maybe
> tcon_capability ?

So this was named intel because it comes under the following structure and is
Called like this
Backlight.edp.intel
Since there are two standards one which is defined by intel edp hdr specs and
One defined by vesa hence the naming intel here plus as you see above when getting
Called it tells us that this pertains to intel edp backlight capability.
I think it makes sense to keep it as is.
Do you still think this needs to be renamed?

Regards,
Suraj Kandpal 
> 
> With the above change
> Reviewed-by: Arun R Murthy <arun.r.murthy at intel.com>
> 
> Thanks and Regards,
> Arun R Murthy
> -------------------
> 
> >  		} edp;
> >
> > diff --git a/drivers/gpu/drm/i915/display/intel_dp_aux_backlight.c
> > b/drivers/gpu/drm/i915/display/intel_dp_aux_backlight.c
> > index 4f58efdc688a..94edf982eff8 100644
> > --- a/drivers/gpu/drm/i915/display/intel_dp_aux_backlight.c
> > +++ b/drivers/gpu/drm/i915/display/intel_dp_aux_backlight.c
> > @@ -158,6 +158,16 @@ intel_dp_aux_supports_hdr_backlight(struct
> > intel_connector *connector)
> >
> >  	panel->backlight.edp.intel.sdr_uses_aux =
> >  		tcon_cap[2] &
> INTEL_EDP_SDR_TCON_BRIGHTNESS_AUX_CAP;
> > +	panel->backlight.edp.intel.supports_2084_decode =
> > +		tcon_cap[1] & INTEL_EDP_HDR_TCON_2084_DECODE_CAP;
> > +	panel->backlight.edp.intel.supports_2020_gamut =
> > +		tcon_cap[1] & INTEL_EDP_HDR_TCON_2020_GAMUT_CAP;
> > +	panel->backlight.edp.intel.supports_segmented_backlight =
> > +		tcon_cap[1] &
> > INTEL_EDP_HDR_TCON_SEGMENTED_BACKLIGHT_CAP;
> > +	panel->backlight.edp.intel.supports_sdp_colorimetry =
> > +		tcon_cap[1] &
> > INTEL_EDP_HDR_TCON_SDP_COLORIMETRY_CAP;
> > +	panel->backlight.edp.intel.supports_tone_mapping =
> > +		tcon_cap[1] & INTEL_EDP_HDR_TCON_TONE_MAPPING_CAP;
> >
> >  	return true;
> >  }
> > --
> > 2.43.2



More information about the Intel-gfx mailing list