<div class="gmail_quote">On Fri, Mar 16, 2012 at 18:41, Takashi Iwai <span dir="ltr"><<a href="mailto:tiwai@suse.de">tiwai@suse.de</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">

Add a new module optoin lvds_channel to specify the LVDS channel mode<br>
explicitly instead of probing the LVDS register value set by BIOS.<br>
This will be helpful when VBT is broken or incompatible with the<br>
current code.<br>
<br>
Signed-off-by: Takashi Iwai <<a href="mailto:tiwai@suse.de">tiwai@suse.de</a>><br>
---<br>
 drivers/gpu/drm/i915/i915_drv.c      |    6 ++++++<br>
 drivers/gpu/drm/i915/i915_drv.h      |    1 +<br>
 drivers/gpu/drm/i915/intel_display.c |    5 +++++<br>
 3 files changed, 12 insertions(+)<br>
<br>
diff --git a/drivers/gpu/drm/i915/i915_drv.c b/drivers/gpu/drm/i915/i915_drv.c<br>
index 308f819..eee6804 100644<br>
--- a/drivers/gpu/drm/i915/i915_drv.c<br>
+++ b/drivers/gpu/drm/i915/i915_drv.c<br>
@@ -80,6 +80,12 @@ MODULE_PARM_DESC(lvds_downclock,<br>
                "Use panel (LVDS/eDP) downclocking for power savings "<br>
                "(default: false)");<br>
<br>
+int i915_lvds_channel __read_mostly;<br>
+module_param_named(lvds_channel, i915_lvds_channel, int, 0400);<br></blockquote><div><br></div><div>As a minor bikeshedding, perhaps this variable would make more sense if called 'i915_lvds_channel_mode' instead?</div>

<div><br></div><div>I am fine with either spelling though, it just looks more semantically correct to me. But in any case,</div><div><br></div><div>Reviewed-by: Eugeni Dodonov <<a href="mailto:eugeni.dodonov@intel.com">eugeni.dodonov@intel.com</a>></div>

</div><div><br></div>-- <br>Eugeni Dodonov<a href="http://eugeni.dodonov.net/" target="_blank"><br></a><br>