<div class="gmail_quote">On Thu, Mar 22, 2012 at 18:39, Jesse Barnes <span dir="ltr"><<a href="mailto:jbarnes@virtuousgeek.org">jbarnes@virtuousgeek.org</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">

ValleyView handles force wake differently than previous chipsets, so add<br>
a couple of new functions for it.  But leave it disabled by default<br>
until we test it (need a chip with the Punit enabled first).<br>
<br>
Signed-off-by: Jesse Barnes <<a href="mailto:jbarnes@virtuousgeek.org">jbarnes@virtuousgeek.org</a>><br>
---<br> #define NEEDS_FORCE_WAKE(dev_priv, reg) \<br>
        (((dev_priv)->info->gen >= 6) && \<br>
         ((reg) < 0x40000) &&            \<br>
-        ((reg) != FORCEWAKE))<br>
+        ((reg) != FORCEWAKE)) && \<br>
+       (!IS_VALLEYVIEW((dev_priv)->dev))<br></blockquote><div><br></div><div>In the spirit of bikeshedding, I think that NEEDS_FORCE_WAKE is becoming a bit scary this way. But I don't know if it makes sense to move the gen and dev check into a feature flag, to avoid similar issues with possible future generations of chips..</div>

<div><br></div></div>-- <br>Eugeni Dodonov<a href="http://eugeni.dodonov.net/" target="_blank"><br></a><br>