<div class="gmail_quote">On Wed, Mar 28, 2012 at 16:46, Jesse Barnes <span dir="ltr"><<a href="mailto:jbarnes@virtuousgeek.org">jbarnes@virtuousgeek.org</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">

<div class="HOEnZb"><div class="h5">> I guess we could have the gen-number stuff be a union of<br>
> IS_IVB()/IS_HSW()/IS_VLV(), and switch chipset probing to using each of<br>
> those instead of just gen >= 4.<br>
><br>
> Does this sound sane?<br>
<br>
</div></div>Yeah that might be better anyway, at least for the kernel where the<br>
IS_GEN stuff is getting more and more overloaded and I'd like to move<br>
away from it in some places.<br>
<br>
So if you're ok with it, that sounds like a good approach.<br></blockquote><div><br></div><div>I think that we could move away from the IS_GEN checks in most places actually, and not just in some of them, by using the feature checks instead.</div>

<div><br></div><div>My latest branch reports gives `grep IS_GEN * | wc -l` = 112; and if we look for recent chipsets, we have `grep IS_GEN[67] *` = 47. And most of those checks have sub-checks as well for specific chip features or names. So if we drop the IS_GEN macros, and just use the specific feature or GPU name checks instead we should improve both the readability and decrease the code complexity I think.</div>

<div><br></div></div>-- <br>Eugeni Dodonov<a href="http://eugeni.dodonov.net/" target="_blank"><br></a><br>