[Libdlo] Recompile the KERNEL...?!!

Greg KH greg at kroah.com
Tue Jan 5 14:53:04 PST 2010

On Tue, Jan 05, 2010 at 04:18:33PM -0600, James wrote:
> Guys:
> Okay -- You are saying that I NEED TO RECOMPILE my kernel to use the
> newest DisplayLink driver -- correct?


> If that is the case, HOW do I recompile this Kernel?! I use the
> realtime Kernel -- not the latest-and-greatest non-realtime Kernel,
> which seems to me gets updated daily. The 2.6.31-9-rt Kernel is older
> -- and does not get updated nearly as regularly. And I need this
> Kernel to run Rosegarden! 

Built it like you would any other kernel, just select the proper
displaylink driver.

> Is it possible to run a SECOND Kernel for the DisplayLink stuff?

2 kernels at the same time?  no.

> I got the git stuff from Plugable. Last time it was super-easy. This
> has complicated things quite a bit. I hope that you aren't seriously
> expecting that the average end-user is going to recompile Kernels.
> Most people don't even know how to use git-core...

Soon, when the kernel driver is settled down, no user will have to do
so, the driver will be included automatically with their distro like all
other drivers are.

hope this helps,

greg k-h

More information about the Libdlo mailing list