[Libreoffice-bugs] [Bug 36501] FILEOPEN: Some Text Colors Reset Cell Formatting to Default in .XLS

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Sat Apr 23 00:21:40 PDT 2011


https://bugs.freedesktop.org/show_bug.cgi?id=36501

Rainer Bielefeld <LibreOffice at bielefeldundbuss.de> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
            Summary|Some Text Colors Reset Cell |FILEOPEN: Some Text Colors
                   |Formatting to Default       |Reset Cell Formatting to
                   |                            |Default in .XLS
             Status|NEW                         |ASSIGNED
         AssignedTo|libreoffice-bugs at lists.free |kyoshida at novell.com
                   |desktop.org                 |
                 CC|                            |LibreOffice at bielefeldundbus
                   |                            |s.de

--- Comment #1 from Rainer Bielefeld <LibreOffice at bielefeldundbuss.de> 2011-04-23 00:21:39 PDT ---
[Reproducible] with reporter's sample document "LibreOffice 3.4Beta2  – WIN7 
Home Premium  (64bit) German UI [DEV300m103 (Build:1)]": some cells are shown
withArial 10 black instead of Arial 12 green
MS EXCEL viewer shows correct colors (pls. see my attahced screenshots), so it
seems to be a LibO bug and not a problem with the document.

Document looks fine with OOo-dev 3.4

But:
Documents having been created by opening with OOo-dev 3.4 and saving as new
.xls or .ods look fine in LibO

Further Test results, pls see test kit:
- Created new Document "MytestfromOOodev340.xls" with OOo-dev3.4
  -- All green text Arial12 will be shown Arial 10 black in LibO
  -- MS EXCEL Viewer will show everything correctly
  -- "MytestfromOOodev340.ods": text shown correctly in LibO
- Created new Document "MytestFromLibo.xls" with LibOBeta2
  -- All green text Arial12 will be correctly in LibO
  -- All Magenta(!) text Arial12 will be shown Arial 10 black in LibO
  -- MS EXCEL Viewer will show everything correctly
  -- "MytestFromLibo.ods": text shown correctly in LibO

My conclusion: formatting in document seems to be correct, but during fileopen
and conversion formatting will be misinterpreted.

@Scott M. Sanders:
How (with what software) has your sample document been created?

@Kohei:
Can you please check?

-- 
Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the Libreoffice-bugs mailing list