[Libreoffice-bugs] [Bug 48327] New: LO crash as normal user

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Thu Apr 5 03:27:59 PDT 2012


https://bugs.freedesktop.org/show_bug.cgi?id=48327

             Bug #: 48327
           Summary: LO crash as normal user
    Classification: Unclassified
           Product: LibreOffice
           Version: LibO 3.5.1 Release
          Platform: ARM
        OS/Version: Linux (All)
            Status: NEW
          Severity: critical
          Priority: medium
         Component: Libreoffice
        AssignedTo: libreoffice-bugs at lists.freedesktop.org
        ReportedBy: tema.prokopenko at gmail.com


LO 3.5.1 Archlinux-armv7h
as normal user i catch segfaults on splash screen. in gdb i see:
"DISPLAY=:0 LANG=C gdb /usr/lib/libreoffice/program/soffice.bin 
GNU gdb (GDB) 7.4
Copyright (C) 2012 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "armv7l-unknown-linux-gnueabihf".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /usr/lib/libreoffice/program/soffice.bin...(no debugging
symbols found)...done.
(gdb) R
Starting program: /usr/lib/libreoffice/program/soffice.bin 
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/libthread_db.so.1".
[New Thread 0x4300b340 (LWP 11023)]
I18N: Operating system doesn't support locale "en_US"
[New Thread 0x43d51340 (LWP 11024)]
[New Thread 0x43d91340 (LWP 11025)]

Program received signal SIGSEGV, Segmentation fault.
0x401a6190 in ?? () from
/usr/lib/libreoffice/program/../ure-link/lib/libuno_sal.so.3
(gdb) bt
#0  0x401a6190 in ?? () from
/usr/lib/libreoffice/program/../ure-link/lib/libuno_sal.so.3
#1  0x401b6138 in ?? () from
/usr/lib/libreoffice/program/../ure-link/lib/libuno_sal.so.3
#2  0x401b6138 in ?? () from
/usr/lib/libreoffice/program/../ure-link/lib/libuno_sal.so.3
Backtrace stopped: previous frame identical to this frame (corrupt stack?)
"
as root lo work fine

-- 
Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the Libreoffice-bugs mailing list