[Libreoffice-bugs] [Bug 45626] New: EDITING: Empty paste of tables from writer tables with mailmerge content

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Sat Feb 4 10:58:56 PST 2012


https://bugs.freedesktop.org/show_bug.cgi?id=45626

             Bug #: 45626
           Summary: EDITING: Empty paste of tables from writer tables with
                    mailmerge content
    Classification: Unclassified
           Product: LibreOffice
           Version: LibO 3.4.5 release
          Platform: Other
        OS/Version: All
            Status: UNCONFIRMED
 Status Whiteboard: BSA
          Severity: normal
          Priority: medium
         Component: Spreadsheet
        AssignedTo: libreoffice-bugs at lists.freedesktop.org
        ReportedBy: silvandy at katamail.com


Created attachment 56608
  --> https://bugs.freedesktop.org/attachment.cgi?id=56608
This is one the writer files obtained with mailmerge. The first 2 tables
exhibit the mentioned problem (those contained in "esercizio 1"); the last
table (that in esercizio 2) works correctly instead when pasted into a
spreadsheet

Problem description: Create a writer text document with some tables. Then
create a database with some data, open it while editing the writer document and
press F4 to insert the database fields into the cells of the writer doc tables.
Now you can press F4 again to leave the database, save the writer file and go
to print command. Since there are database field in the tables, you are
requested if you'd like to perform a mailmerge print: say Yes, and print many
copies of the document with different rows of data each.
Finally, open one of the merged writer output files: all data from the database
appear to be correctly in place.
However, when you try to copy and paste some of the tables in it into a calc
spreadsheet, the data merged from the database (and visible in the text
document) turn to zero or empty cells when pasted into the spreadsheet. This
does not happen always: it does for some tables and not for others.
Actually this happens when you paste normally the writer table with database
data inside (in this case the result are empty cells) or when you paste it
special as a html format (and then you get zeros in the destinations cells). If
you paste special it as unformatted text the data is not lost, but the format
of the table it totally lost, making is unusable.

The practical context where this behaviour spells big troubles is the creation
of exam files with the same exercises for all students, but different data for
each one. Students should receive one .odt file, read the task, copy the data
included and paste it into calc for data analysis, but with some tables they
get zeros in place of the data they see into the writer document.

Expected behavior: It should be possible to paste all tables of the writer file
with data merged from a database inside the calc file without getting zeros in
some cases.

Platform (if different from the browser): 

Browser: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0) Gecko/20100101
Firefox/10.0

-- 
Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the Libreoffice-bugs mailing list