[Libreoffice-bugs] [Bug 44544] New: EDITING : When filter applied, auto fill erased hidden cells

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Fri Jan 6 12:35:30 PST 2012


https://bugs.freedesktop.org/show_bug.cgi?id=44544

             Bug #: 44544
           Summary: EDITING : When filter applied, auto fill erased hidden
                    cells
    Classification: Unclassified
           Product: LibreOffice
           Version: LibO 3.5.0 Beta2
          Platform: Other
        OS/Version: All
            Status: NEW
          Keywords: regression
          Severity: critical
          Priority: high
         Component: Spreadsheet
        AssignedTo: libreoffice-bugs at lists.freedesktop.org
        ReportedBy: gerard.fargeot at orange.fr


LibreOffice 3.5.0 beta2 running on Windows Vista.

Auto fill with filter emptied hidden cells.
Step by step :

1. Open attachment
2. In autofilter : column A, deselect all, then select only "lundi".
3. Apply the filter. Rows 2, 9 & 16 are visible.
4. In cell B2, type 1
5. Fill down with fill handle (+ at the right end corner of the cell)

Expected : Cells B2, B9, B16 with 1. Other not changed.
Current : Cells B2, B9, B16 displays 1,2,3. Other cells are empty !

It is a regression from 3.4.4

-- 
Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the Libreoffice-bugs mailing list