[Libreoffice-bugs] [Bug 49853] EDITING: Cannot paste into 'find' box (OS X)

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Sat May 26 08:32:22 PDT 2012


https://bugs.freedesktop.org/show_bug.cgi?id=49853

Roman Eisele <bugs at eikota.de> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|RESOLVED                    |REOPENED
         Resolution|DUPLICATE                   |
     Ever Confirmed|0                           |1
          Component|Spreadsheet                 |UI

--- Comment #4 from Roman Eisele <bugs at eikota.de> 2012-05-26 08:32:22 PDT ---
Please forget my comment #2, it was a mistake: bug 49706 is, of course, very
similar, but still a mistake. Sorry! Therefore I REOPEN this bug report and add
here all information which has been collected in between:


(I) This bug affects not only Calc (for Calc, see original description), but
also Writer (therefore I change the Component field to "UI"). To reproduce it,
use the following steps:

1) Copy some text to the clipboard.
2) Start LibreOffice.
3) Open a Writer document (.odt)
4) Press Cmd+F (= Ctrl+F for Windows): Find.
5) The Find toolbar appears and gets the focus; the curser is blinking inside
the find edit field.
6) Press Cmd+V (= Ctrl+V for Windows): Paste.

Expected behaviour: The text copied in step (1) is pasted into the Find edit
field, because it has the focus.

Current behaviour: The text copied in step (1) is pasted somewhere into the
main text of the Writer document.


(II) This bug is REPRODUCIBLE on MacOS X (10.6.8, Intel Mac, German UI) with

1) LibreOffice 3.4.4, German langpack installed.
2) LibreOffice 3.5.3.2 (Build-ID: 235ab8a-3802056-4a8fed3-2d66ea8-e241b80),
German langpack installed.
3) LibreOffice 3.5.4.1 (Build-ID: 7306755-f4f605c-738527d-1cf4bc1-9930dc8),
German langpack installed.
4) LOdev 3.6.0alpha0+ (Build ID: 2398b9c; date: 2012-05-24),
US English langpack installed.

I don't have a copy of LibreOffice 3.4.0 around, but it seems probable that
this bug is present in LibreOffice for MacOS X since the new Find toolbar was
implemented.


(III) This bug is NOT REPRODUCIBLE with LibreOffice 3.5.3.2, German UI, on
Windows XP; in Writer and Calc everything works as expected (i.e., the edit
field of the Find toolbar gets the text from the clipboard if I press Ctrl+V).

Therefore, this bug seems to be MacOS X only.


(IV) TODO: Can someone please verify if the bug is present on Linux? There is
at least a similar, possibly somewhat related issue on Linux (bug 47634).

-- 
Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the Libreoffice-bugs mailing list